0

I upgraded a site from EE 1.7.3 to EE 2.9.1 - the last piece was upgrading Playa. The site was working fine until that point. When I went to upgrade Playa, I received the following error:

Error Number: 1060 Duplicate column name 'parent_element_id' ALTER TABLE exp_playa_relationships ADD parent_element_id VARCHAR(255) NULL AFTER parent_var_id Filename: third_party/playa/ft.playa.php Line Number: 488

After checking for parent_var_id and parent_is_draft (both exist) I went to set the version number to 4.5 in exp_fieldtypes - however there is no playa field listed in that table.

Also, now the site and control panel do not load and instead I'm getting:

Site Error: Unable to Load Site Preferences; Invalid Preference Data

Thanks for any help you can provide.

  • Which version of Playa do you have installed? You could try updating to the latest, just released Playa 4.5.1 version. – SyA Aug 6 '14 at 18:31
  • 4.5, which was the version available this morning. I'll try 4.5.1 – Mel Aug 6 '14 at 19:02
  • 1
    I just redid the entire upgrade again, upgrading to Playa 4.4.5 first and then after that was working, I upgraded to 4.5.1 – Mel Aug 11 '14 at 22:22
  • Good find, it's always recommended to update add-ons first, then EE. – Mark Busnelli Jr Sep 26 '14 at 18:12
1

Here's the solution to the above issue: https://expressionengine.stackexchange.com/a/24657/189

in short, run this SQL and run module updates again:

UPDATE  `exp_fieldtypes` SET  `version` =  '4.5' WHERE `name` =  'playa'
| improve this answer | |
  • Sadly, I did try that and it did not work for me. – Mel Aug 28 '14 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.