0

Hopefully I'm missing something obvious but cannot get MX Maps to work with custom third party theme folders.

The module appears fine when using the config_override for: 'third_party_path' for modules but when I override 'theme_folder_path' + 'theme_folder_url' to custom folders - I get a JS error on front end.

mysite.com/themes/third_party/mx_google_map/mxgooglemap.js'

All other modules + extensions work fine with the override :(

EE:2.8.1

MX Map: 1.5.3.140526

4
  • is error exactly as you show it? Where exactly this error? In CP or in frontend? Because in module I use mxgooglemap.min.js (not mxgooglemap.js) for CP. But if it is front end - this url is going from your template, not from module settings. – Max Lazar Aug 12 '14 at 6:17
  • Ya see, I mentioned I was missing something. Reply as an answer and will mark accordingly :) Thx! – stuartmcd69 Aug 12 '14 at 6:28
  • Hmm, that being said. When I edit config to point to a separate and custom theme folder (NOT /themes) it errors in the CP. Appears it doesnt recognise path_third_themes or url_third_themes. – stuartmcd69 Aug 12 '14 at 6:36
  • hm... it is weird because I use ee()->config->item('theme_folder_url') for urls, so it is must be overwrite. Is this error on publish page? Could you please check next line in your files? It is the same? github.com/MaxLazar/mx-google-map-v1/blob/master/system/… and as I mention before - in my files is no links to mxgooglemap.js, only to mxgooglemap.min.js. The link is entered on Publish page for channel which use MXGM for fieldtype. – Max Lazar Aug 12 '14 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.