0

I'm using the USPS shipping extension and receiving the below error on the checkout page:

Fatal error: Uncaught exception 'Store\Exception\ShippingException' with message 'Authorization failure. Perhaps username and/or password is incorrect.' in /mypath/assets/third_party/store_usps/ext.store_usps.php:135 Stack trace: #0 [internal function]: Store_usps_ext->shipping_methods(Object(Store\Model\Order), Array) #1 /mypath/expressionengine/libraries/Extensions.php(262): call_user_func_array(Array, Array) #2 [internal function]: EE_Extensions->universal_call('store_order_shi...', Object(Store\Model\Order), Array) #3 /mypath/expressionengine/libraries/Extensions.php(119): call_user_func_array(Array, Array) #4 /mypath/assets/third_party/store/src/Store/Service/OrdersService.php(159): EE_Extensions->call('store_order_shi...', Object(Store\Model\Order), Array) #5 /mypath/assets/third_party/store/src/Store/Tag/CheckoutTag.php(61): Store\Service\OrdersService->get_order_shipping_methods(Object(Store\Model\Order)) #6 /mypath/assets/third_party/s in /mypath/assets/third_party/store_usps/ext.store_usps.php on line 135

This error seems similar to this one. I am sure that I have the correct username in the extension. There's no field to place the password.

1

I ran into the same problem. I created an account with USPS.com and assumed that that was the username I should be using in the USPS Plugin for Store.

Turns out USPS has a separate registration for API access. You can find that here: https://www.usps.com/business/web-tools-apis/welcome.htm

They'll send you an email with a generated username that you can use for API access. Once you change the username in the USPS Plugin settings to the username they generate for you the error should go away.

I got some new errors, regarding the (package) container, but after I tweaked some settings in the extension it seems to be working fine.

  • Cool! I gave up trying to get a USPS dev account. I'm in Canada and their signup form just gives me an error page. My US client created an account, but by the time I went to use it, it didn't work. USPS tech support by email takes a month to receive a response. So, I just hard-coded the shipping and gave up. – jeremyhoover Mar 10 '15 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.