2

So Im trying to upgrade an EE site and when I follow the instructions... All I get is a black white page. No error messages, nothing.

Interesting when I enable debug=1 in index.php, I do see this error: Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or '$' in /var/www/vhosts/default/htdocs/run/EllisLab/ExpressionEngine/Core/Autoloader.php on line 46

Any ideas or hints really appreciated.

I dont have any special modules or plugins.

Paul

3

The error points you to line 46 of the Autoloader.php file. That line of code is:

if ( ! isset(static::$instance))

This line of code will only run in PHP 5.3.0 or newer.


ExpressionEngine 2.9 requires PHP 5.3.10 or newer and you're getting the error because your PHP version is older than this.

| improve this answer | |
  • You saved me from having a complete breakdown, for this I am grateful! – Kieran McClung Feb 16 '15 at 13:55
  • Happy to help!! – Anna_MediaGirl Feb 16 '15 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.