0

In 2.5.3 with Playa 4.3.3, the following setup worked, but after an upgrade to 2.8.1 and a rebuild of the channel:form, submissions are not working.

I have a channel:form, with several input fields that are submitting correctly. I also have an embed that contains a channel entries loop, so I can display video previews, plus the checkbox for the Playa field. I had this working before in the same setup (same field and channel), but now when it submits, no relationships are made.

{exp:channel:form dynamic_title="[order_tv_retailer_name]" channel="store_tv_orders" return="{segment_1}/{segment_2}/order/ENTRY_ID" entry_id="{segment_4}" error_handling="inline" datepicker="no" use_live_url="no" include_assets="no" include_jquery="no" class="form-horizontal form-bordered" site="msm_site"}

{!-- INSIDE OF EMBED {embed=""} --}
{exp:channel:entries channel="tv_commercials" disable="category_fields|member_data" site="msm_site" search:tv_commercials_brand="{site_short_name}\W"}

{tv_commercials_asset kind="=video" var_prefix="file"}

<input type="checkbox" id="order_tv_selection_{entry_id}" value="{entry_id}" name="order_tv_selection[selections][]" class="form-control" required>

{/tv_commercials_asset}             

{/exp:channel:entries}
{!-- END OF EMBED --}

.....more input fields that submit correctly.....

{/exp:channel:form}

The intention is to make a Playa relationship using channel:form and an embed that loops through the channel entries I would like to relate. I'm following the documentation for a channel:form checkbox for Playa to a tee (http://docs.pixelandtonic.com/playa/templating/channel_form.html).

Thank you for any suggestions and assistance!

1
  • I should include that the only thing that changed from the 2.5.3 installation to the 2.8.1 install is the inclusion of five MSM sites. I've tried the form on the primary site, plus the virtual sites and submitting to Playa does not work on any of them. – Stephen Aug 29 '14 at 14:08
0

Not could have a relation with member_data category? It is disabled on your channel field parameter.

4
  • 1
    Thank you for suggestion. That's a good thought, but I'm not using any member data or categories, so they're not needed. I tested it anyway and still no dice. – Stephen Aug 29 '14 at 13:58
  • You're welcome. I hope you will find a solution, this problems never occured with me. Try do update Playa, now it's version 4.5.1 – Stéphane Aug 29 '14 at 17:23
  • 1
    That did it Stephane! Thanks for the catch. I thought all add-ons were already updated, but updating to 4.5.1 of Playa fixed it. – Stephen Sep 2 '14 at 14:48
  • You're welcome! Inside EE, when a lot of plugins are installed, it's not always easy to be in date. This plugin helps you to know wich plugins are out of date (lamplighter): devot-ee.com/add-ons/lamplighter – Stéphane Sep 2 '14 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.