0

I am a new user of Expression Engine and the version I am using is 2.5.2 and whenever I try filling the contact us form unto submission, I have the following error.

Error after Form Submission

Kindly note that CAPTCHA is not enabled and I dont know what else might be the problem.

Can you point me in the right direction?

Another issue is that, the CAPTCHA Image is not coming up.

While trying to save a change made under the CAPTCHA preferences, I got the error message below; CAPTHA ERROR

5
  • Please include your template code. Is CAPTCHA disabled in the CP or are you assuming that it is disabled because it is not being shown on the form? – foamcow Sep 24 '14 at 8:43
  • Please how to I enable CAPTCHA in the cP? – Olanrewaju Olukosi Sep 24 '14 at 9:12
  • Admin->Security and Privacy->CAPTCHA settings. Or type "CAPTCHA" into the search box on the sidebar of your CP. – foamcow Sep 24 '14 at 9:18
  • It is enabled. The post has been edited... CAPTCHA is not even showing on the form. – Olanrewaju Olukosi Sep 24 '14 at 9:20
  • Please post your template code. It is impossible to help you otherwise. – foamcow Sep 24 '14 at 9:33
1

If CAPTCHA is enabled and the image isn't showing then it could be a couple of things.

  1. Your CAPTCHA directory isn't writeable so EE can't create the image.

  2. You don't have the CAPTCHA code in your form.

Since you are getting the error message I would guess that it's option 1.

But, please post your template code otherwise it's all guesswork on our part.

3
  • Hi, Thanks for the solution. As you can see above in the edited question, the folder is not writable and I think I have to tell the website hosting to make it writable. – Olanrewaju Olukosi Sep 24 '14 at 9:38
  • If this is the solution then please mark the answer as correct by ticking the button next to it. Thanks. – foamcow Sep 24 '14 at 10:19
  • 2
    You can make the directory writable in your FTP program. Permissions should be set to 777 on the directory as the error indicates. Each FTP program is different so you'll need to figure out how on yours. Usually you click on the specific directory and get a menu that has change permissions options. Or have your host do it if that is what they do. – Anna_MediaGirl Sep 24 '14 at 16:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.