0

We have a reset/forgot password form (let's call this Form A) in a template that allows the user to enter the email address they signed up with (below) - this works by the way.

Form A

{exp:user:forgot_password}

    <input type="text" name="email" id="email" placeholder="Email Address"/>
    <input type="submit" name="submit" value="Submit" />

{/exp:user:forgot_password}  
  • Once completed, this sends the user a unique link to reset their password (example.com/member/reset_password?&id=XXXXXXXX), which when you click on takes you to a dynamically created EE "Please Enter A New Password Page" with a form (Form B) for which there is no template that I can see.
  • When you create your new password within this page, this works, but it redirects the user back to the original custom reset/forgot password form specified above that they completed (Form A).

This is pretty bad UX, so we'd like to redirect the users to a login page, or at very least to the site homepage. How can we do this there's no template that allows us to intervene?

Thanks!

3

You can add parametr password_reset_template=

{exp:user:forgot_password password_reset_template="user/reset_password/%id%" }

    <input type="text" name="email" id="email" placeholder="Email Address"/>
    <input type="submit" name="submit" value="Submit" />

{/exp:user:forgot_password} 

and then create template for reset password where you can set url for return

<h2>Reset Password</h2>
<p>
    This form will allow you to reset your password.
</p>
 
{exp:user:reset_password
    reset_code="{segment_3}"
    return="user/reset_success"
}
    {if user_no_results}
        <h4>The reset token provided is invalid.</h4>
    {/if}
 
    <h4>Reset Password</h4>
 
    <p>
        <label for="password">New Password</label><br/>
        <input type="password" name="password" />
    </p>
 
    <p>
        <label for="password_confirm">Confirm New Password</label><br/>
        <input
        <input type="password" name="password_confirm" />
    </p>
 
    <p>
        <input type="submit" value="Submit" class="submit" />
    </p>
{/exp:user:reset_password}
| improve this answer | |
  • Thanks for the response. This doesn't seem to be working unfortunately :( - Just tried disabling the template we had enabled for the reset instructions and that didn't work either unfortunately. It just sends the standard link (example.com/member/reset_password?&id=XXXXXXXX), which takes you back to the default Form B. Just realised, we're not using Solspace User which would explain it, we're using Zoo Visitor and the standard EE password reset functionality. – jx3 Sep 25 '14 at 17:31
  • in this case you better to replace template in your question to show correct add-on which u use. And as I can see, Zoo Visitors also have the same functions ee-zoo.com/docs/visitor/tags/… starting from EE2.6.0. What ee version u use? – Max Lazar Sep 25 '14 at 17:51
  • Ah yes, I think we tried using those forms a while ago and they didn't seem to work for some reason. Just tried again and works perfectly. Thanks for your time and help! – jx3 Sep 27 '14 at 12:47
  • Glad to hear you're up and running. If you're using another add-on than User, I suggest changing the code/wording in the opening post, and remove solspace/User-related tags. :) – Solspace Oct 27 '14 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.