I just installed Solspace Rating module and included the rating form like this:

{exp:rating:form entry_id="{entry_id}" allow_duplicates="no" anonymous="yes" collection="neueroeffnungen" return="bewertung_danke"}
    {if not_duplicate}
        {if logged_out}
            <input type="hidden" name="name" value='Guest_{current_time format="%U"}' />

        <select name="rating" id="rating">
            <option value="1">1</option>
            <option value="2">2</option>
            <option value="3">3</option>
            <option value="4">4</option>
            <option value="5">5</option>

        {if captcha}

        <input type="submit" name="submit" class="submit" value="Rate" />

It works great if I don't require a captcha, but if I do, I always get:

The captcha you submitted is incorrect.

Any idea what I'm missing?

EE v2.8.1 - Build: 20140314
Solspace Rating 3.2.3

2 Answers 2


Try setting the module preferences here:

Modules > Rating > Preferences

Use Captcha? set to "yes"


You are missing the captcha input, where the value for validation should go.

Something like:

<input type="text" name="captcha" value="{captcha_word}" autocomplete="off" size="20" required />

And as far I have some experience with Solspace products you should check what expression they are using for captcha. For example if you're using freeform - it is something like:


or something.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.