1

Anyone else seeing this issue?

This has been this way since at least 2.81 and I just upgraded to 2.92 and it's still happening

Heres what I have:

{exp:channel:entries channel="artworks" paginate="both" limit="36" orderby="artwork-end_year|artwork-viewing" sort="desc|asc" cache="yes" refresh="360"}
{if count == 1}
All ({absolute_results})
{/if}
{/exp:channel:entries}

This shows "All (36)"

While this:

{exp:channel:entries channel="artworks" paginate="both" limit="36" orderby="artwork-end_year|artwork-viewing" sort="desc|asc" cache="no" refresh="360"}
{if count == 1}
All ({absolute_results})
{/if}
{/exp:channel:entries}

This shows "All (239)"

I've cleared the cache a number of times but still get the same result? Any ideas?

1

I can't replicate this locally, so I'm not sure it's a bug.

Is that all the code you're actually using to test this? Because if you don't include {paginate} tags, then {absolute_results} will always be the same (or less than) your limit parameter. (The existence of {paginate} tags is what actually triggers pagination.)

Add a {paginate} loop and see if this issue persist between cached and non-cached.

1

I am also seeing this issue on EE 2.9.2 as of May 5, 2015. I turned off Channel Caching
(Admin > Channel Administration > Global Preferences > Cache Dynamic Channel Queries?) and it seems to have fixed the problem.

If you want to keep caching globally but remove it in a few cases like this one, you can add cache="no" as a parameter to the exp:channel:entries loop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.