I'm having this strange thing when I search for items in EE. Whenever I search for an item having the name "89580.32" this doesn't work. If I add a letter to it, it seems to work. The solution is obvious, just add a letter and that's how I was thinking about solving, though I will forever be wondering why this is as it is.

I have already tried: - Changing the database field type to varchar - Adding a number to make sure it would be indexed (because of it being to short maybe?) - Deleting the point ...which all didn't work.

Is there anyone out there who can shed some light on this? I assume it's because of it being looked at as a number instead of text?

Update: It's when searching using the search:customer_field inside the EE channel entries tag

  • Are the search terms being logged? Enable the log and make a test, please.
    – Sobral
    Oct 13 '14 at 18:11
  • I think I wasn't clear on this, sorry. It's not when using the EE search function, it's when using the search:customer_field inside the EE channel entries tag. I've added this in my question above. Oct 14 '14 at 14:34
  • It looks like a bug, to me. Please, report it.
    – Sobral
    Oct 14 '14 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.