2

Running EE 2.3 and trying to upgrade, the first error is a message which says:

We have detected that you are currently running ExpressionEngine version Public Beta pb01 If you are ready to update ExpressionEngine to version 2.5.0 click the link below:

Which is odd in itself as it is not a public beta but v2.3.

Then there are a slew of errors relating to duplicated tables and no primary key - these are all fixable in PhpMyAdmin by deleting or editing but is a major pita.

Next, with those errors fixed we run into one for which I have no solution: the installer stalls because a field/table prefixed with 'weblog_' does not exist. Which of course it does not as we're not upgrading from V1. Obviously though the installer thinks we are and won't go further.

Is pretty imperative we get this upgrade done asap.

Anyone have any suggestions? This is on EngineHosting and they can't help.. what's next? Can't really abandon the upgrade....

Cheers

  • 1
    I've seen something similar happen before when I had a ternary operator in my config.php file (setting the DST config item dynamically). It threw the upgrader for a loop and thought you were upgrading from EE "0", essentially. Anything like that in your config.php? – Derek Hogue Oct 30 '14 at 12:24
  • 1
    Hmm... there's some in there with '$conf' instead of '$config', that's from old V1 isn't it? Would that do it? – segovius Oct 30 '14 at 20:55
  • @segovius the $conf variables simply wouldn't be recognized unless you do an array merge to populate $config with $conf – Steve Buzonas Feb 11 '15 at 21:03
1

I've had problems such as this before. The answer was to make a note of the problems and then modify the database manually accordingly so that the installer can cope with the changes. This is usually a problem when there is a significant difference between the current version and the one you are upgrading to.

I wrote a blog item about a particular upgrade which might help to point you to the right direction: http://www.climbingturn.co.uk/tech_tips/expressionengine-tips-and-tricks/expressionengine-upgrade-271-to-290/

I hope that helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.