0

Today a site I administer started getting a 404 error when trying to access the CP at www.thedomain.com/admin.php

It was working fine and as far as I know there have been no changes to the system by the client.

A user reported getting the error 'disallowed key characters' - though I have not seen this, for me it just redirects to the site 404 page.

The only thing that is different is that they sent an mail out earlier today (batched in 100s - approx 2000) that might result in high bandwidth/traffic in response, I am not sure if that would impact it though.

Can anyone help shed some light?

2

Firstly, can you confirm that the admin.php file actually still present on the server?

Secondly, you mentioned the disallowed key characters message.

Are you setting 2 lots of Google Analytics cookies? Third party services may also be setting Analytics cookies. I had this problem recently with an old Typekit kit which resulted in one of the cookies being renamed using a ~ character which fell foul of EE's allowed characters. In the case of Typekit they stopped doing this long ago but old kits need to be republished and for some reason it only recently became a problem.

I don't know why this would cause a 404 error though so it could well be unrelated.

1
  • Thanks for your answer Foamcow.. I was just coming here to give my answer.
    – segovius
    Nov 4 '14 at 12:12
1

This got solved by a dialogue with the hosts. They claim it was 'wrong permissions' on the admin.php file but I am not sure if this is the case. Especially as they advised me to change all FTP passwords and would not give further info when I requested their logs.

Anyway, it's working again now. Sorry I can't give further info on the fix for anyone in the same position.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.