0

I’m running into something that isn’t making sense to me … I have a client that has created this page: http://teamthroughmywindow.org/about-our-project/faqs

The questions and answers are all anchor links, etc. and they used WYGWAM to create all of them. The rest of the site uses WYGWAM as well and they CAN edit other pages successfully right now (meaning CKEditor initializes just fine.) On this page the editor doesn’t initialize and it freezes up the browser.

My question is this … are there any size limits / issues with the link tool when so many anchors are used? They were able to save the revised page (there is a lot more content now). If not, can you offer some insight into where I may look to resolve this. I’ve tried clearing the cache in EE and in the browser (ran into a similar issue during EE upgrades in the past and that was a browser cache issue but that doesn’t appear to be the case here as I would expect them all to fail).

I look forward to your reply.

1
  • That content is 26k characters, could it be something like a limit in the textarea field? My other though is why are they using a blob for structured content surely "FAQ's" belong in their own channel? Nov 13 '14 at 20:12
1

Have this figured out. Steven's fix he mentioned with changing the field from TEXT to LONGTEXT was part of the fix. The other part was that there was some bad HTML in the field that caused WYGWAM to choke. (Found this by pulling the field content from the DB and dumping it into coda and syntax highlighting showed errors). Specifically it was this (double quote closing a element):

After I changed the double quoted to single quotes on "Rio's Brain" it worked perfectly.

Thanks for everyone's help on this one.

1
  • ah yeah, I've seen that before. Nov 17 '14 at 12:32
0

Depending on the content of the field, you may be hitting a limit.

I've seen this happen with thesis like articles for a client. This resolved it for us Wygwam character limit?

2
  • Steven ... if I alter this to longtext there is no risk of losing the data in this column? It does appear to be a limit issue in the field but I need to be careful here as this is a production site. Also, would this mess up future upgrades (or rewrite this column back to text)? (Forgive me, it's 5:30 on a Friday, thus my uber caution here!) Nov 14 '14 at 22:27
  • I changed the character limit in the DB but getting the same issue. Nov 15 '14 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.