0

n00b to EE, just installed the free version 2.9.2 on ubuntu 14 VPS

I have moved the system folder one level up and am able to login ok

hitting /index.php gives me a login screen to the cp

I followed the quick hello world tutorial and created a page which should appear at /index.php/site

however, the url always/only resolves back to /index.php?/cp/login&return=

I am logged in at the time when i get this login screen

Can not find anything on the googles on this. thanks in advance

1

Your index.php shouldn't be showing your Control Panel - admin.php should do that. Sounds like you've modified the index.php file incorrectly. Not sure what instructions you've followed, but I'd revert back to the original install index.php and admin.php and start here: Removing index.php.

And for moving your core folder you should follow these instructions. You should really have only needed to modify the $system_path = '../system' variable in both index.php and admin.php (unless you've renamed your admin.php file for additional security);

Supply an example of your htaccess folder if you're still having grief.

| improve this answer | |
  • thanks for the reply mate, i think it was not .hataccess but something i did when i moved the system folder. I reinstalled and now works correctly but i have left system folder in the original location – user3636703 Nov 27 '14 at 9:36
  • 1
    It's really easy to move the folder to above root, so worth it for the extra security. Also suggest you rename the system folder name as it's only specified in the admin.php and index.php files. Then also under the Admin settings. Highly recommend Deeploy Helper which pulls all the settings into one place to change easily: devot-ee.com/add-ons/deeploy-helper – Peter Lewis Nov 27 '14 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.