0

I'm using the sample Ellis Lab code almost verbatim for my RSS feed. When I set the template type to web page, it outputs correctly. When I change it to RSS, I get an empty feed. Right now it is set to RSS. Ideas? http://sequentlearning.com/rss

{preload_replace:master_channel_name="blog"}
{exp:rss:feed channel="{master_channel_name}" status="open"}

<channel>

<title><![CDATA[{channel_name}]]></title>
<link>{channel_url}</link>
<description>{channel_description}</description>
<dc:language>{channel_language}</dc:language>
<dc:creator>{email}</dc:creator>
<dc:rights>Copyright {gmt_date format="%Y"}</dc:rights>
<dc:date>{gmt_date format="%Y-%m-%dT%H:%i:%s%Q"}</dc:date>
<admin:generatorAgent rdf:resource="http://expressionengine.com/" />

{exp:channel:entries channel="{master_channel_name}" limit="10" disable="member_data|pagination" dynamic="no" status="open"}
<item>
  <title><![CDATA[{title}]]></title>
  <link>{title_permalink='site/index'}</link>
  <guid>{title_permalink='site/index'}#When:{gmt_entry_date format="%H:%i:%sZ"}</guid>
  <description><![CDATA[{summary}{body}]]></description>
  <dc:subject><![CDATA[{categories backspace="1"}{category_name}, {/categories}]]></dc:subject>
  <dc:date>{gmt_entry_date format="%Y-%m-%dT%H:%i:%s%Q"}</dc:date>
</item>
{/exp:channel:entries}

</channel>

{/exp:rss:feed}
  • 1
    Can you duplicate that template in a template with the "web page" type to show what should be outputting? – Derek Jones Dec 5 '14 at 17:31
2
+25

I'm seeing a literal "empty_feed" which indicates that you are missing some language files or that they are out of date. To me that puts a question to the state of other files, too, so refreshing your files may be in order (though might not fix the issue. I've commented for some more info, and can update this answer after you've tried that.

| improve this answer | |
0

Well, that's weird. I refreshed the code and now it works. Ghosts in the machine? Thanks for your help.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.