0

I've upgraded EE our production and QA environments with no problem (both IIS), but when I tried to upgrade EE on my local environment (WAMP 2.2), I get stuck with this screen after accepting the terms and conditions:

blank screen during EE update

Anyone else encounter this? How did you get around this?

1

Something similar - possibly a plugin not responding. Remove third-party plugins in your system folder, try updating again and then return your plugins...you should update fine, and then you'll need the third-party items back in to open the control panel.

| improve this answer | |
  • Good point. I'm inclined to think that this is not the case here, only because the update worked as expected on the production environment (our production server matches each local environment in nearly every way). – Vince Falconi Dec 10 '14 at 23:33
1

Since posting my question, I haven't figured out why this happened, but I did come up with a workaround for it:

  1. Import your upgraded production environment's MySQL database on your local environment*
  2. Follow the update instructions from EllisLab up to but not including step 6.
  3. Change $config['app_version'] in system/expressionengine/config/config.php to 292
  4. Delete the system/installer folder
  5. Open your ExpressionEngine CP and you should be running 2.9.2 as you hoped and dreamed

*If importing a dump of your production DB isn't something you normally do, be aware that the following things will need to be updated after you complete your import:

  • DB: channel_url in exp_channels (for each channel), example query:

    UPDATE `[YOUR DB NAME]`.`exp_channels` SET `channel_url`='[YOUR URL]' WHERE `channel_id`='[YOUR CHANNEL ID]';
    
  • DB: server_path in exp_upload_prefs for each upload destination, example query:

    UPDATE `[YOUR DB NAME]`.`exp_upload_prefs` SET `server_path`='[YOUR LOCAL PATH]', `url`='[YOUR LOCAL URL]' WHERE `id`='[YOUR UPLOAD DESTINATION ID]';
    
  • CP: URL to the root directory of your site in Admin > General Config

  • CP: Theme Folder Path in Admin > General Config
  • CP: Server path to site's templates in Design > Templates > Global Template Preferences
  • CP: File path in Add-Ons > Extensions > Low Variables > Extension Settings

These are the things we have to update in our setup, so your milage may vary. Godspeed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.