0

I have a template that is making a request to remote CSS & JS files that are hosted on the same server, different domain:

{exp:minimee:js}
    <script>https://www.remotesite.tld/assets/js/plugins/cycle.js</script>
    <script>https://www.remotesite.tld/assets/js/init/index.js</script>
{/exp:minimee:js}

When I try to load the page, the browser gets stuck in loading-mode for several minutes before throwing a "page not available" error.

If I disable Minimee in my config, the page loads without issue:

$env_config['minimee']['disable'] = 'y';

No server errors are logged when this happens.

  • EE 2.9.0
  • Minimee 2.1.12
4
  • Does anybody know why this is resulting in a "page not available" browser-side error instead of a HTTP timeout error or just Minimee failing silently?
    – kmgdev
    Dec 10 '14 at 22:44
  • What happens if you copy those assets to local and source them local? Wondering if its a remote thing. Dec 11 '14 at 0:35
  • 2
    Can you try changing Minimee's settings to use file_get_contents() instead of cURL when fetching remotes? Dec 11 '14 at 13:39
  • @JohnDWells FGC worked! If you want to post that as an actual answer I'll mark it as correct.
    – kmgdev
    Dec 11 '14 at 19:42
1

By default, Minimee tries to fetch "remote" assets using cURL; if you find that your server setup somehow doesn't like this, you can try configuring Minimee to use file_get_contents() as an alternative.

--

If it is possible for Minimee (or PHP more specifically) to access those assets via the filesystem, then you can try to "map" the external URL to the physical location, with a combination of setting your base_path and base_urls. You can pass these as tags rather than global configs:

{exp:minimee:js
    base_path="/path/to/www.remotesite.tld"
    base_url="http://www.remotesite.tld"}
    ...
{/exp:minimee:js}

With that set, when Minimee encounters that remotesite URL, it will replace it with the base path, and then attempt to fetch their contents.

0

What is the HTTP Status code? 500?

It could be related to a bug on 2.9.0 See here for a fix: https://support.ellislab.com/bugs/detail/20471/site-index-template-is-rendered-after-the-404-template

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.