0

I have set the 404 page on Templates > Global Template Preferences, but it is having no effect.

I do not want to turn on 'Enable Strict URLs' as it cause several problems on some pages. And anyway, I don't mind if http://www.domain.com/product/not-the-right-url defaults to /product, or the last channel entry in /product.

What I do want is that http://www.domain.com/not-the-right-directory defaults to the 404 page.

The problem is the setting in Global Template Preferences is having no effect on the site. All that happens is that you see the home page if you type in the wrong URL.

The site is running EE 2.9.0 on a Plesk 12.0.18 Apache Server.

1

Specifying the 404 page doesn't cause it to appear in 404 situations - you need to do more work yet.

You pretty much have to turn on strict urls in order to setup a basis for the 404 template to show. Strict urls ensure that segment 1 is a valid template group name. From there you'll need to handle deeper 404 situations at the template level.

This article is a great overview of the 404 management in EE: http://joviawebstudio.com/index_ee.php/blog/guide_to_404_pages_with_expressionengine/

If you have a template where turning on strict urls causes issues that should be addressed separately.

| improve this answer | |
  • I really enjoyed the fact that the great overview link is now a 404 page :-) – Sally Felton Oct 6 '17 at 10:17
  • Your links go on no where. Please update URL. – Mufi - Amici Infotech Oct 6 '17 at 13:23
  • Second that... link heads to 404 page. – Denny Smith Feb 2 '18 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.