0

I've upgraded EE to 2.9.2 and have found some strange behaviour with Transcribe. The problem is that some channel entries did not have a language set in the exp_transcribe_entries_languages table. This was not a big problem because I could just run a script to fix the issue.

However, I have found that entries created via channel:forms do not even get an entry in the exp_transcribe_entries_languages table which means that these entries will not get displayed to the user.

e.g. A member entering a delivery address. This address is stored but no record is created in the exp_transcribe_entries_languages table so that address will never be of use. There must always be a valid language_id mapped to each channel entry for it to be displayed correctly.

How can I fix this?

  • have you tried parsing the language_id in a hidden field? – Jelle Dijkstra Dec 17 '14 at 7:48
  • Thanks for the suggestion Jelle Dijkstra. I tried adding this: <input type="hidden" name="language_id" value="1"/> hard coding the correct language id but this has no effect. I've emailed eeHarbor, they sent me an new version but no luck there either. – dorothy Dorothy Dec 18 '14 at 12:20
  • Same issue here. When I edit an entry by channel form it save the entry without his language. But if I add transcribe='disable' to my exp:channel:entries tag transcribe use is null. Has anybody found a soludtion to make transcribe work with Channel forms?? Thanks – pikarge Jun 21 '17 at 11:01
0

The answer is to use this parameter in your tag pair:

transcribe="disable"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.