When I use an ampersand (&) in a Category name with spaces in a certain order I get an error that does not allow me to submit the change. Using EE v.2.9.2.

Error: "The data you submitted did not pass our security check."
This seems to be the "invalid_xss_check" error.

I have tried to change the Category group to "Allow all HTML" and to also encode all HTML but I get the same results.

Here is what works and what doesn't work (screenshot below).

Works:

  1. "One[space]&[space]Two"
  2. "One&[space]Two"

Does Not Work:

  1. "One&Two" ( <--- This is the one I want )
  2. "One[space]&Two"
  3. "One[space]&amp[space]Two" - (going insane...)

Screenshot: Category Errors

  • @foamcow is right, thanks. I want: > One&amp;Two – Cheyney Dec 27 '14 at 0:45
  • FWIW I got this same error when attempting to submit Category Description html with inline style elements, e.g. this is rejected <a class="nobarlink" style="display:inline; padding: 0.5ex; margin:0;" ... while this is ok: <a class="nobarlink" .... Ideally it's better to solve this upstream in the template CSS, but frustrating to have to add yet another special case for one category in a site-wide resource. I just used mysql workbench to edit table directly. Oh well, at least I know why because of this thread. Thanks for that. – matt wilkie Jan 14 '15 at 18:42
  • I can't edit the table because this is for the users to play with. I still haven't found the rules for what can and can't be done. – Cheyney Jan 18 '15 at 6:31
up vote 2 down vote accepted

Try

One &amp; Two

Note the semi-colon after the HTML entity - you missed that on your version.

  • Doh... I love you. – Cheyney Dec 27 '14 at 0:42

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.