0

I have a template that is supposed to display only one entry.

Instead it is pulling all entries from the particular channel and not paying any attention to the dynamic='no' parameter.

I have created many versions of this template, removing more and more code including changing the template group and name but nothing seems to work. It even ignores the "limit" parameter

Version: EE 2.9.2 using Switchee to parse segments 2 and 3

Channel Entries Tag:

{exp:channel:entries channel='products' dynamic='yes' disable='categories|category_fields|member_data|pagination|trackbacks'}  

Sample Url:
http://example.com/products/wardrobes/cover
Segment 1: products - Template Group
Segment 2: wardrobes - Category not used by anything in channel entries
Segment 3: cover - URL Title

Switchee Template: products/index.html

{exp:switchee variable='{segment_2}' parse='inward'}
{case value="''"}
    {embed='products/_products-home'}
{/case}

{case default="Yes"}
    {switchee variable='{segment_3}' parse='inward'}
        {case value="''"}
            {embed='products/_products-category'}
        {/case}
        {case default="Yes"}
            {embed='products/_products-entry'}
        {/case}
    {/switchee}
{/case}
{/exp:switchee}
  • did you try adding limit="1"? – Jelle Dijkstra Dec 19 '14 at 8:46
  • Yes. Like I said in the post "It even ignores the "limit" parameter". This is driving me nuts. – Cheyney Dec 19 '14 at 21:35
  • Did you try it without "trackbacks" as a disabled parameter? As far as I know that's not a valid option for 2.9.2 ellislab.com/expressionengine/user-guide/add-ons/channel/… – Romans-8---31-39 Dec 20 '14 at 1:42
  • I haven't yet but will give it a go. The strange thing is this code is working for three other channels with only the channel name different. Same, exact, code. – Cheyney Dec 20 '14 at 4:34
2

Have you tried url_title="{segment_3}"?

| improve this answer | |
  • That's how I got it to work. The issue seems to be that one of the segments is a category name but I am not using a category trigger word nor do I even have that turned on. I wanted to do more tests on this but had to deploy and I haven't gone back to play with it. – Cheyney Jan 3 '15 at 3:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.