3

I'm having trouble on an install of EE 2.8.1. This is the first time I've seen this php error, and it bugs me. It doesn't seem to be causing any real problems, but it messes up the font sizes on the CP. Any ideas on what may be causing this?


A PHP Error was encountered

Severity: Warning

Message: file_get_contents(/chroot/home/---/---/system/expressionengine/cache/current_version): failed to open stream: Permission denied

Filename: drivers/Cache_file.php

Line Number: 74

4

Check that your cache directory's permissions are set to 777 so that it's fully readable/writeable.

  • 1
    The cache directory was 777, but the "current version" file was not. The server had set itself as the owner of the file and blocked public access to it. After a couple of rounds with tech support, we got the ownership worked out, so we're good now. No PHP error anymore. – user3776457 Jan 12 '15 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.