0

Not sure really what type of issue this is, but I figure I'll ask here. I have a site that's running live on the server right now which has the following error:

A PHP Error was encountered
Severity: Notice
Message: unserialize(): Error at offset 0 of 326 bytes
Filename: drivers/Cache_file.php
Line Number: 74

This error does not happen locally, only live. The only difference I can see is that on the live server the templates are synched, whereas locally they are not.

I am running EE v 2.8.1, php 5.5.9. Permissions on my cache directory are 777.

3

After speaking with Derek privately I was able to resolve the issue which is a permissions error. The steps taken to solve this are:

Via FTP/SSH navigate to system/expressionengine/cache and delete everything with the exception of .htaccess and index.html .

Afterwards, change your permissions on system/expressionengine/cache to be 777 then restart your server.

| improve this answer | |
  • That might get rid of the PHP error, but that will effectively break file-based caching. Can you share how you concluded that was the correct conclusion? – Derek Jones Mar 31 '15 at 21:49
  • This is actually pretty disappointing. The post is three months old, received only one comment, then when an answer is posted it's downvoted with literally no help in resolving the perceived issue. The problem was the error was making the backend unusable. Commenting that code out fixed it. Thus the issue was resolved. May it break some things? Yes. But without alternative solutions, this is the answer to the question that was asked. – thatgibbyguy Mar 31 '15 at 23:59
  • I can only speak for myself but I asked a question to help you get to the correct solution. Your suggestion hides rather than fixes the problem. If you elaborate on your answer, I'm sure the community can help you come to an accurate conclusion that would also help others. How did PHP versions come into play, for instance? Were you having this problem on one version of PHP but not another? What were the contents of the bad file? – Derek Jones Apr 1 '15 at 0:43
  • Worth mentioning too that this isn't an implementation question, so I'm not sure someone on StackExchange could answer for you outside of someone debugging on your server or examining your cache files. Did you try EllisLab support? – Derek Jones Apr 1 '15 at 0:44
  • This topic needs to be closed. It's not an EE problem, it's a CodeIgniter problem. StackOverflow would be a better place. I've answered why I provided it as a solution because it solved the problem I was trying to solve. There's no expansion needed. – thatgibbyguy Apr 1 '15 at 14:55
0

I would try clearing the cache from within the control pannel

| improve this answer | |
  • Yeah, tried that, still no luck. So bizarre. Regardless, 2.8.1 is so damn buggy. I'm just going to update it to 2.9.2 and start updating add-ons. This version of EE has been nothing but problems. – thatgibbyguy Jan 16 '15 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.