1

Multipage form on a site that is using Structure. The form is built in the Composer and added to the page with a custom field from the publish page.

Obviously page one works as the url is www.domain.com/name-of-page-with-form

But when I click through to page two of the form www.domain.com/name-of-page-with-form/page2, I am getting a 404 page not found. So I tried using Freebie to ignore that last segment but it looks like it is making FreeForm ignore the segment as well, thus displaying the first page of the form still.

Is there a way to use Structure and FreeForm Pro Multi Page forms??

  • Structure messes with how EE (and add-ons) normally interpret URLs and their segments. I haven't tried this myself (very little experience with Structure), but have heard that Freebie helps in making EE/Add-ons read URLs normally ("natively") again. It might just be a matter of tweaking Freebie. – Solspace Jan 26 '15 at 2:32
  • Mark, Have you find a way to achieve it? If you did can you explain how you did it, please. Francois – worfoual Mar 6 '15 at 15:12
  • Sorry no. I took it out of Structure in the end and used EE URL's – Mark Mar 12 '15 at 15:26
0

When I have a Channel entries with paging on and Structure I also use the add-on switchee. May be it can also help with a FreeForm Pro Multi pages form.

{exp:switchee variable="{segment_2}" parse="inward"}

{case value="#^Page(\d+)$#|''"}
Put here your Form
{/case}

{/exp:switchee}

It could work.

Francois

  • Hi Francois, I couldn't get this working.. – Mark Jan 25 '15 at 13:34
0

I know this is an old question which has some sort of resolution but for others that are interested I've found a potential fix.

  • Create a new template and assign it to the page that contains (or is likely to contain) the form
  • Go to Design > Templates > Template Route Manager
  • Find your template and add the following: {page:alpha_dash}/{page:alpha_numeric}

This works perfectly well with my site setup. You can also assign the template / template route to a parent page i.e. parent-page/{page:alpha_dash}/{page_no:alpha_numeric}

0

Try using the Freebie addon and add "page1", "page2", "page3" etc to the list of segments to ignore. Then in your composer tag add the parameter multipage_page="{freebie_last}"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.