0

All of my images have no thumbnail preview in the CP.

All images uploaded are automatically set to: 666 Owner: 99 Group: 99

I can't change it through ftp or the the Media Temple file manager

EE: v 2.92 Media Temple DV server

I do have assets installed but I'm not sure if that matters

1

Sounds like you need to change your uploads directory permissions. The non-generation of thumbnails pretty much verifies that it is a permissions problem.

First, take a general look at the EE Upgrade Instructions, in particular the section on Verify File Permissions. Check everything matches the recommendations.

Then check your File Manager Permissions in Control Panel > Content > Files. Make sure you have your upload directory defined.

Finally, if you are allowing users to upload files via the Control Panel, the web server daemon user:group (typically apache:apache or www:www) needs to have write permission to the uploads directory. Try to avoid making permissions 777 (which is global read/write/execute) and just enable read/write for the web server daemon. This should be a simple check and fix that you can do via your FTP agent. Good luck.

3
  • Thank you for the response, but I had already tried that. The issue seems to be with thumbnails generated by EE. I also can't change the ownership or permissions on these files through ftp or cpanel. – SteveO Feb 9 '15 at 20:25
  • According to the Media Temple FileManager docs you can modify both file and folder permissions. You should just be able to modify permissions of the thumbnails directory using it. – tatlar Feb 9 '15 at 21:35
  • The thumbnails directory will be in the following location on your server: /path/to/eesite/images/uploads/_thumbs. So you want images/uploads (and any subdirectory) to have write permission by the web server. – tatlar Feb 9 '15 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.