I'm having a problem similar to this one where I can't save large matrix fields on my site. Large, in this case, is > 200 rows with 3 fields each where 2 of those are asset fields. EE/Matrix/Assets/Fieldpack are all up-to-date and I've increased max_input_vars to 1500, max_execution_time to 600 and memory_limit to 256; still no luck. I just get a blank screen, no error message, no error in logfile.

Should I just stop trying to use matrix for this and adopt a different design, or should this work?

2 Answers 2


1) read server logs 2) turn debugging on in index.php

This should help you understand better where the problem is.

I have lots of issues like that and Usually it is a matter of server configuration but you must start reading and identifying the error from logs



Have you tried with more memory or higher max_execution_time? I'm running 1024M. Also max_input_time:60

When I had problems with that on one site I had the max_execution_time lifted to 12000 & its fine but I've never used that many Matrix rows.

I think you should be able to get this working but may need to have the available server resources cranked up.

  • Thanks Damien - I tried increasing all these php config values but no luck. Previously I was getting errors in my PHP log file about exceeding the number of input vars, but once I extended that I'm not getting any php debugging output - I have a feeling I'm encountering a webserver process timeout here. Feb 17, 2015 at 17:03
  • Sorry to hear that didn't work. For what its worth, I put all of my EE sites on Nexcess shared hosting & have very few of these types of issues compared to cPanel hosting. Might not be the solution but could be worth spinning up a dev account to see if it gets you out of the jam. Feb 18, 2015 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.