1

I’ve found many threads both here and elsewhere on session timeout in the CP, however I’ve yet to see a solution that works.

One of my clients is complaining that the timeout is too short, and so far I haven’t been able to extend (preferably indefinitely) it.

I’ve also tried with both session and cookies, session only, cookies only.

Any help with this issue on 2.9.2?

Thanks!

1

Well, have you tried the terrible idea of modifying core files? In 2.9.2 you can try modifying system/expressionengine/libraries/Session.php and edit line 74:

public $cpan_session_len    = 3600;  // Admin sessions expire in one hour
1

I believe the session time variable may have been deprecated in recent EE updates, since it is no longer listed in the EE knowledge base for config variables:

$config['cp_session_ttl'] = 'insert number value here';

Default is/was 3600 seconds for that value.

Have you tried as an alternative setting the cp_session_type variable in your config.php:

$config['cp_session_type'] = 'c';

When set to cookies only (value of c), rather than using sessions (s or cs for sessions + cookies), you should then see an option on the cpanel screen next time you login to 'Auto login on future visits?'

the login will remain valid for up to 2 weeks I believe, so even on closing the CPanel, navigating back to the page later should log back in automagically.

Not a direct answer I know, but hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.