0

I'm updating a client site to EE 2.9.2 from 2.5.1. Along the way I'm also updating the build of Low's NoSpam extension. Once installed it's throwing the following CP error:

A PHP Error was encountered Severity: Notice Message: Use of undefined constant LOW_NOSPAM_CLASS_NAME - assumed 'LOW_NOSPAM_CLASS_NAME' Filename: libraries/Accessories.php Line Number: 106

I've re-downloaded/installed the files and uninstalled/reinstalled a couple times to no avail...

Any ideas?

  • The latest version of Low NoSpam doesn't have an accessory. Is the acc.low_nospam.php file still there, or is it deleted? – Low Feb 20 '15 at 7:50
  • Yep - that was it. Thanks Low - did I miss a note about that somewhere? – Michael Boyink Feb 20 '15 at 12:31
  • Not really, but when you update an add-on, be sure to delete the old files, instead of replacing the package, which could actually merge the old and new files. – Low Feb 20 '15 at 12:35
0

The latest version of Low NoSpam doesn't have an accessory. Make sure the acc.low_nospam.php file is not present in the add-on package.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.