0

Just downloaded the free version of EE and I already hate using it. I can log into EE successfully but every time I hit "view rendered template" it sends me to another login screen and if I go back in that tab and hit "View rendered template" it takes me yet again to another log in screen and the url shows me this admin/index.php?/cp/login&return= Needless to say this is annoying beyond belief. I've looked at these answers (Q1,Q2,Q3) but with no success on my end. Any and all help is appreciated.

Below is my config.php file

$config['app_version'] = '292';
$config['license_contact'] = '';
$config['license_number'] = 'CORE LICENSE';
$config['debug'] = '1';
$config['cp_url'] = 'http://example.com/ee/admin/index.php';
$config['doc_url'] = 'http://ellislab.com/expressionengine/user-guide/';
$config['is_system_on'] = 'y';
$config['allow_extensions'] = 'n';
$config['cookie_httponly'] = 'y';
$config['cp_session_type'] = 's';
$config['index_page'] = 'index.php';
$config['cookie_domain'] = "";
$config['cookie_path'] = "";
$config['cookie_prefix'] = "n";
$config['require_ip_for_login'] = "n";
$config['require_ip_for_posting'] = "n";
$config['secure_forms'] = "n";

I've tried it mainly in Chrome but also tried it in FF with no success

If any more info is required i'd be more than happy to provide it.

  • The core version doesn't contain the Member module. store.ellislab.com See the comparison chart at the bottom of the page. – Jim Wyse Feb 23 '15 at 23:35
  • Have you set access permissions on the template you're trying to view so that only logged-in users can view the template? Or do you have the system turned off? (Under Admin → General.) Those would be reasons why EE wants you to login to view the template. What is the full URL you see in the status bar when you hover over the "View Rendered Template" link? – Derek Hogue Feb 24 '15 at 13:59
  • @DerekHogue If you're talking about setting permissions in apache with the 666 and 777 I did do that yes. The system under admin/general is ON. The full url is example.com/ee/admin/?URL=example.com/ee/admin/site As i look at my FTP i realize that there is no site file in my admin folder. Could that be the ultimate issue? – user6076 Feb 24 '15 at 14:16
  • I was speaking of template access restrictions, not Apache permissions. But it seems to me that your install is not setup correctly - a root install URL when viewing the default site index should be simply example.com. Have you renamed your system folder? Have you renamed your index.php file? – Derek Hogue Feb 24 '15 at 15:02
  • My apologies, as for the Template access, I hit Select all YES. I renamed the system folder the first time and it didn't work for me so I reinstalled and just kept it as "system" for now. And I have two index.php files but don't think I renamed either. One in the admin folder and the other in the ee folder itself. – user6076 Feb 24 '15 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.