0

I've tried both of the below and category 18 is still being outputted in the category list.

Version 1

{exp:channel:categories category_group="1" category="not 18"}
<a href="{path='shop/index'}">{category_name}</a>
{/exp:channel:categories}

Version 2

{exp:channel:categories channel="{product_channel}" category_group="1" category="not 18"}
        <a href="{path='shop/index'}">{category_name}</a>
{/exp:channel:categories}

Strange thing is it was working previously.

0

The parameter "category" is not valid for the channel:categories tag.

You need to use " show='not 18' ". I am not sure how it was working for you before.

See: https://ellislab.com/expressionengine/user-guide/add-ons/channel/categories.html#show

Channel Category Parameters

1
  • Thanks Cheyney, I completely missed this. I must have swapped it at some point. Thanks – MBM Feb 25 '15 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.