1

About to upgrade my personal site and went to Ellislab website for download and they have 2 versions for download. 2.81 and 2.92

Going through the EE bug tracker appears I may have several items that I will need to edit core files if I end up with these all ready listed bugs.

Is there a reason some of us would not want to upgrade to 2.92 now? with Forums 3.1.17?

I'm currently running 2.81.

Thanks `mike

1
1

In cases like this, you should check out the Change Log.

There are a couple of changes that stand out:

  • EE2.9 requires at least PHP 5.3.10 (EE2.8 requires 5.2);
  • In EE2.9, the conditionals parser has had an overhaul. This means your templates can be more performant, but conditionals are also more error-prone.

As so often, it's a case of YMMV.

3
  • Sorry should have mentioned i also looked through the change logs as always, but this is the 1st time I have seen EE offer 2 versions for download. Guess i'm more worried about what might break add-ons – user2437 Feb 26 '15 at 14:27
  • I think that, by now, most add-ons will be 2.9 compatible. If you're unsure, ask the developers. – Low Feb 26 '15 at 15:35
  • The security updates in 2.9.x vs 2.8.x are significant as well. Unrelated, but something to consider since you're thinking about updating: on the PHP requirements, if you need to request an upgrade from your host, go ahead and ask for PHP 5.5–there are many free performance gains. – Derek Jones Apr 27 '15 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.