0

The question pretty much says it, but here is some additional info:

Config file, with "siteurl" taking place of the real url:

$config['minimee'] = array(

    /**
     * ==============================================
     * BASIC PREFERENCES (REQUIRED)
     * ==============================================
     */

    /**
     * The path to the cache folder.
     * Defaults to site's FCPATH + '/cache'
     */
    'cache_path'        => '/var/www/vhosts/siteurl.com/cache',

    /**
     * The URL to the cache folder.
     * Defaults to $EE->config->item('base_url') + '/cache'
     */
    'cache_url'         => 'https://www.siteurl.com/cache',

    /**
     * ==============================================
     * BASIC PREFERENCES (OPTIONAL)
     * ==============================================
     */

    /**
     * Turn on or off combining of CSS assets only. 'yes' or 'no'.
     * Values: 'yes' or 'no'
     * Default: yes
     */
    'combine_css'       => 'yes',

    /**
     * Turn on or off combining of JS assets only. 'yes' or 'no'.
     * Values: 'yes' or 'no'
     * Default: yes
     */
    'combine_js'        => 'yes',

    /**
     * Turn on or off minifying of CSS assets. 'yes' or 'no'.
     * Values: 'yes' or 'no'
     * Default: yes
     */
    'minify_css'        => 'yes',

    /**
     * Turn on or off minifying of the template HTML.
     * Values: 'yes' or 'no'
     * Default: no
     */
    'minify_html'       => 'no',

    /**
     * Turn on or off minifying of JS assets.
     * Values: 'yes' or 'no'
     * Default: yes
     */
    'minify_js'         => 'yes',


    /**
     * ==============================================
     * DISABLING MINIMEE
     * ==============================================
     */

    /**
     * Disable Minimee entirely; aborts all activity
     * and returns all tags untouched.
     * Values: 'yes' or 'no'
     * Default: no
     */
    'disable'           => 'no',


   );

The only difference (besides https) between this site and other sites on which I have it installed & active and it works, is that that this server (client owns it) does not have an http(s)docs folder. Not sure if that is why the whole thing is being thrown off.

The CSS is wrapped in tags like this. JS files are done the same way:

{exp:minimee:css}
    <link rel="stylesheet" type="text/css" href="/css/style.css" />
    <link rel="stylesheet" type="text/css" href="/css/mobile.css" />    
    <link rel="stylesheet" type="text/css" href="/css/bootstrap-responsive.css" />
    <link rel="stylesheet" type="text/css" href="/css/bootstrap-responsive.min.css" />
{/exp:minimee:css}
5
  • 1
    Can you elaborate on "doesn't work"? Have you turned on template debugging and looked at Minimee's messages there? Feb 25 '15 at 19:39
  • @DerekHogue: By doesn't work, I mean it is neither minifying nor combining the JS or CSS. There are no errors (for anything) showing in debugger. Feb 25 '15 at 20:20
  • Just to clarify - not console errors, but the EE Template Logger. Minimee should log messages there every time it is called. Feb 25 '15 at 20:50
  • Thank you for your help. In doing that, I discovered that the I had forgotten to make the cache folder writable. Feb 25 '15 at 21:10
  • Glad that sorted it, I'll post an answer. Feb 25 '15 at 21:24
1

Turn on Template Debugging under Admin → System Administration → Output and Debugging, then reload your template. Minimee will give you helpful logging messages in the template debugger at the bottom of the age.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.