1

I'm running into a problem when trying to use Multiple Site Manager (v2.1.7) with ExpressionEngine (v2.9.2). This is a fresh install on Digital Ocean. The only posts are ones created by following the tutorial at https://ellislab.com/expressionengine/user-guide/how_to/building_a_simple_news_site.html. I used the instructions on Ellis Lab's site to install MSM. The first time that I try to enable MSM, the page posts, but "Enable Multiple Site Manager" switches back to "No". The second time I enable it, the setting is saved corrently. If I try to do anything at this point I get the Site Error. Disabling MSM in config.php makes the site work just fine. The second I re-enable MSM, the site throws the error again.

Here's what I've done to try and troubleshoot.

  1. I checked open_basedir in php.ini. It's commented out, but I also changed the value to the document root (/var/www/html in my case).
  2. I checked (and changed) all the permissions as described at https://ellislab.com/expressionengine/user-guide/installation/installation.html.
  3. I checked the database settings in database.php and they're correct.
  4. I've tried uninstalling EE and MSM and dropping the database, but I'm still getting the error.
  5. I ran the EE wizard and everything looks okay on that end.

Any ideas? I don't know what else to check.

1
  • Did you get this fixed? – paulcripps Nov 24 '15 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.