0

I realise this is a an incredibly vague question, but asking just in case someone recognises symptoms and can suggest a possible cause that I can go investigate...

[if you haven't worked out I'm new to EE...]

I'm trying to migrate a site from one server to another server.

I've migrated the server using the instructions in EE documentation, and believe I've done those steps as required.

The site works perfectly on the current server.

On the new server the site will only show the home page, regardless what URL you enter (i.e. site_URL plus any trailing text gives home page).

The URL entered is preserved in the displayed browser URL.

I turned on template debugging, and this is what I see when I try go to any page that is not the index page - you'll see it seems to ignore the URI: (it is blank for some reason) and then loads /index...

(0.000013 / 4.53MB) - Begin Template Processing -
(0.000144 / 4.53MB) URI:
(0.000155 / 4.53MB) Path.php Template: /
(0.000165 / 4.53MB) Retrieving Template
(0.000175 / 4.53MB) Parsing Template URI
(0.000197 / 4.53MB) Retrieving Template from Database: /index

Anyone with any ideas?

Couple of clarifications based on questions asked.

First, the new server is simply another instance on the same hosting platform that we use for the current site instance - the idea is to build a test server that we can use to test module updates / do development on that is in the same hosting environment as the live site.

The hosting is done by a firm called TSOHost in the UK and is the "Cloud Hosting" package (https://www.tsohost.com/web-hosting).

Second, is the complete .htaccess file from the current server (on which EE is working no problem, and has been copied over to the new server instance):

AddType x-httpd-php53 .php

Header set X-UA-Compatible "IE=edge"

<IfModule mod_rewrite.c>
RewriteEngine On

# Removes index.php from ExpressionEngine URLs
RewriteCond $1 !\.(gif|jpe?g|png)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php/$1 [L]
</IfModule>
ErrorDocument 403 http://2gc.eu/pages/sorry-that-link-cant-be-used
# Added automatically by Gridhost panel Wednesday 27th of March 2013 06:45:28 PM
Options -Indexes
  • You've updated ALL path variables to reflect the new environment? Can you access the CP ? – stuartmcd69 Apr 2 '15 at 1:37
0

Did you copy over the .htaccess file from the old server? It may have been invisible to you and thus not been copied.

  • Yes - good call. I did copy it over - but I do wonder if there is something wrong in it that might be causing the problem. I copied it across as-is, as I couldn't see anything in it that was site-specific. Here is what is in it now <IfModule mod_rewrite.c> RewriteEngine On # Removes index.php from ExpressionEngine URLs RewriteCond $1 !\.(gif|jpe?g|png)$ [NC] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ /index.php/$1 [L] </IfModule> – JCOGS Design Mar 1 '15 at 14:32
  • The .htaccess script I used is the one that is used on the current server. I tried changing the .htaccess script to be identical to the one included in the ellislab.com user guide (link) but it made no difference to this issue at all. – JCOGS Design Mar 1 '15 at 15:06
  • What company host the new server? – Justin Long Mar 1 '15 at 20:16
  • TSOHost in the UK - (tsohost.com) – JCOGS Design Mar 3 '15 at 0:07
0

The hosting company may determine small changes in your .htaccess file. Some require

RewriteBase / 

for example, or something similar. So that might give us a clue if you can post that.

  • See updated question for details. – JCOGS Design Mar 3 '15 at 0:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.