I'm using Freeform 4.1.8 and EE 2.8.1 . I have a Freeform form with an upload file field. It's uploading all files ok, except docx .

I've checked that docx is in the mimes.php file, the upload directory is set to all file types. I've tried adding in allowed_file_types="*" to Freeform but it's still not working.

My Freeform code looks like this:

 {exp:freeform:form collection="applications"
  require_captcha="yes" }

My File upload Field looks like this:

 {freeform:field:upload_cv show="1" allowed_file_types="*"}

The error message I'm getting

Edit: I set up a Channel Form to see if I could upload docx files through that, and it worked fine. It looks like it's just Freeform that won't let me upload them.

  • Can you update your question to clarify: When you say "not working" what do you mean exactly? – AllInOne Mar 5 '15 at 16:45
  • Hi, I've edited the question to include a screenshot. I just get the screen above with the message. – Mark Mar 5 '15 at 17:10

Freeform 4.2.1 and 4.2.2 brought a number of bug fixes for upload handling (some reported by me). See the change log for details.

I'm not certain what you are seeing is a FreeForm bug but I would definitely recommend updating before going too deep into troubleshooting.

| improve this answer | |
  • Hi, thanks for help. I've updated to 4.2.2 but the issue is still there. All files upload correctly, except .docx – Mark Mar 5 '15 at 11:23

Turns out it was a simple fix, In Freeform > Fields > Field Settings > Allowed File Types I had dox instead of docx.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.