1

I simplified the form what Im using with Charge atm. to point out with what I have issues.

I have this form:

{exp:charge:form
                form_class="form-horizontal"
                form_id="charge-form"
                return="client/thankyou"
                return_error="client/errors"
                plan_amount="69"
                plan_currency="eur"
                plan_length="12"
                on_success="premium_membership"}

                       <label for="card_name" class="col-sm-2 control-label">Name on the Card</label>

                        <div class="col-sm-4">
                          <input type="text" class="form-control" id="card_name" value"" data-stripe="name" />
                        </div> 

{/exp:charge:form}

and this is on the "receipt" page:

{exp:charge:info hash="{segment_3}"}

 <strong>Name on the Card:</strong> {card_name}

{/exp:charge:info} 

But it does not show the name put to the field. Stripe does take and save that data to proper place on their end, but on my site, its blank.

I've looked at the charge documentation that clearly says card_name is available, even its optional. http://squarebit.co.uk/software/expressionengine/charge/docs/tags#tag-info

When doing business to business payments, I need the name of the client to be included to receipt to make it legal for added to accounting on the client end.

However, if I use just customer_name, I do not get the right data saved to Stripe end. And I cant use data-stripe for customer_name because it is not the same as the name of whos paying.

What I have might done wrong, or does the card_name has to be inside of specific tags or so?

All other fields like card number, and card used is coming out as normal, and the amount paid.

Please, i've heard that there is thousands of ppl who uses Charge, so this has to be something that has easy solution?

Using EE 2.9.2 running on PHP 5.6.2

Thank you.

0

I just got email from addon developer that card_name appears to have some sort of bug on the version of Charge im using. So if someone else might have had same issue, I just want to let you know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.