0

Im attempting to update page content (template content more specifically) in vim over ssh and have experienced trouble with the changes being committed.

For example:

I have a common footer template where I am changing some information. Through ssh, I navigate to the file, open in vim, and write the changes. everything is ok to this point

I go to the website and the change has not been committed… even with hard refresh.

Then, if I navigate to the same footer file in the web interface, the change still isn't present. If I go ahead and make the change there, as you would imagine, it works just fine.

So my question is:

Is there some cache setting or configuration option that makes editing the template files directly on the server as functional as committing changes through the gui?

1

1) Verify the template files system path is correct:

Design > Templates > Global Preferences

2) Generally speaking, you can clear the current cache by navigating to "Tools > Data > Clear Caching". You can also try deleting all of the cache files in the /system/expressionengine/cache/ folder but I haven't tried that for this type of scenario.

2
  • Does the issue sound like a cache problem? I was just making a guess because I couldnt come up with a better explanation. Im not entirely sure if EE is even setup to be edited that way, or furthermore, if it can be setup for that type of workflow. – visyoual Mar 11 '15 at 13:26
  • It sounds like a caching issue to me. That is, I think the cache is cleared automatically when you save a template via the backend. Check to see if you have Template Caching enabled on any of your templates (or via your Templates' Global Preferences). – JBB Mar 19 '15 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.