1

I am taking over a website from previous developers who used ExpressionEngine. When I upload a new image via ExpressionEngine, it is not visible. I have tried to upload the image through the File Manager and through its own entry. Here is what I see in Safari when I try to view the image through the CMS. I just see a question mark when I view it on the actual webpage.

enter image description here

What is the problem here? The size of the image is correct, and when I download the image from the File Manager, I can view it on my computer. Is there something I'm missing here?

0

If you can successfully upload images yet thumbnails not showing it could be

a) File permissions on the upload folder are incorrect (inc. thumbnail directory) or

b) you don't have GD library (double check docs as to required server image module) on your server

Does it show within the entry ?

4
  • The upload folder is filled with images that are being displayed correctly that the old developers had already placed on the website. It's just new images that I'm uploading now that don't display correctly. They don't display correctly on the website either, so it's not just a thumbnail problem.
    – Eric
    Mar 12 '15 at 14:22
  • Definitely sounds like a permissions issue. Be sure your /images/uploads folder is set to either 775 or 777 depending on your server setup. Syncing your files might be a good idea too to see if EE is seeing all of your files. Mar 12 '15 at 15:40
  • Thanks Mark. Can I do that without command line access to the server? Is there a way to do that via ExpressionEngine?
    – Eric
    Mar 12 '15 at 17:13
  • No you cannot alter file/folder permissions within EE. That is a server side option, Amy decent ftp app should be capable Mar 13 '15 at 1:54
0

Also check the "URL of Upload Directory" path in the File Upload Preferences entry for the directory. I had an extra "public" in there because I stupidly copied too much of the file path into the URL path field. I could see the thumbnails in the _thumbs directory and everything had the correct permissions. The problem was the URL path that caused the Control Panel and the site to have an invalid URL to the thumbnail and hence all I saw was the unavailable image icon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.