1

I'm currently in the midst of developing a new EE site and it has been going relatively well. Up until now when I've run into a peculiar problem which I have never encountered previously. (at least 6 other sites running EE currently)

The problem arises whenever I come to create a new template group within the template manager as the title says. I hit the create group button enter the details and hit save. It redirects back to the template manager as is normal only the new template group does not show up in the template manger list to the side ultimately preventing me creating templates for that group.

Having checked the database table for template groups the group itself has been created as a new row in the database:

Database Table showing new row added.

I have tried deleting this row and recreating it within the template manager again however I still get the same issue. My next port of call was to check the template base path and this is correct. I am currently developing in two environments both local and a dev server so my next attempt was to try it on the dev server as I thought it may have been an issue with my local version. Again it just would not create correctly.

My final attempt to remedy this issue was to compare previous installs of expression engine all of which still work fine and will create template groups when I add new ones. No difference and again I could see no problem with my settings from site to site.

All versions of expression engine are 2.9.2.

If anyone could shed any light on how this could be happening and how I can remedy this issue I would be most appreciative as it has put my dev on hold as I need that new template group to continue.

Thanks.

  • "template base path" - sounds like permissions on the folder. If the base template folder has the wrong permissions, the newly created template folder will adopt them, which may not be writeable, therefore the database entry will be created, but the folder and file won't be (or is, but isn't readable). Ensure the templates folder is chmod 777 and recursively set...? – Peter Lewis Mar 17 '15 at 9:37
  • Thanks Peter, I have checked permissions and they are set to 777 recursively. Would this stop the template group from showing up in the template manager? I mean even if the folder was not being created would the template group not still show up within the template manager? – CFA Digital Mar 17 '15 at 9:43
  • Yes it should still work - hence the suggestion via comment, not an answer - was worth a try! :) Check exp_templates table for index row created for that group. I assume you're super admin? Have you got any add-ons that could be conflicting? – Peter Lewis Mar 17 '15 at 9:59
  • Thanks Peter, On your suggestion I checked the templates table for the newly created row for the group. Nothing was being created so I inserted a new row manually and the template group now shows up in the template manager. Clearly my expression engine install is running into a problem when it tries to create the template in the database. – CFA Digital Mar 17 '15 at 10:14
  • Check your database schema - it can't be the global, as it managed to write to the template group, but an individual table schema could have got borked to prevent creation...? Very remote, but worth checking! – Peter Lewis Mar 17 '15 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.