• EE 2.9.2
  • Solspace User 3.5.1

I've got a front-end member "forgot password" form on a site that uses Solspace User and Focuslab config and I'm removing index.php with .htaccess.

My profile_trigger config value is hardcoded in the Focuslab config to an obscure string:

$env_config['profile_trigger'] = '1ue985h60r92ynd9475ht9v7'; //rand(0,time());

This usually this works like a champ, but the password reset link in the email is going to EE's 404 page.


I've tried inserting index.php into the URL string to no avail:


.htaccess looks like this

RewriteEngine On
Options +FollowSymlinks

RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
RewriteRule ^(.*)$ https://aoma.edu/$1 [R=301,L]

RewriteCond %{HTTPS} off
RewriteRule ^(.*)% https://%{SERVER_NAME}%{REQUEST_URI}

RewriteCond $1 !\.(gif|jpe?g|png)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f 
RewriteCond %{REQUEST_FILENAME} !-d 
RewriteRule ^(.*)$ /index.php?/$1 [L]

I can't find anything wrong with this setup but EE keeps showing 404 on the reset_password link.

Any suggestions?

  • Can you post your User code in the above question? Have you had a look at the password_reset_template="" parameter (solspace.com/docs/user/forgot_password/#password_reset_template)? From the docs: "Without this parameter, User will send the default reset token to the user which will use ExpressionEngine's built-in reset password form."
    – Solspace
    Mar 24, 2015 at 14:12


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.