0

I'm getting this odd message with Wyvern - it won't load the default editor, nor let me save new editor toolbar configurations. Everything else is working in EE, the system path is set correctly.

enter image description here

1
+50

It seems that you may have renamed the /system directory and/or admin.php to something else (which is a great idea). If so, you need to change the $system_path variable to be updated in all three of these locations:

/index.php
/admin.php (or renamed version)
/system/index.php (or renamed version)

Example: If you renamed /system to /cantguessthis you would need to set the variable like so in /index.php and /admin.php:

$system_path = './cantguessthis';

You would need to set it like so under /cantguessthis/index.php (this one actually doesn't change in this case):

$system_path = '';

If you moved /system outside of the docroot (also a good idea), for instance into your home directory at /home/sburrell/expressionengine, then you would need to set the full path in index.php and admin.php:

$system_path = '/home/sburrell/expressionengine';

You also need to make sure cp_url is set correctly in your config.php file. It should be set to the full URL to /admin.php OR /system/ OR /system/index.php, depending on how you prefer to login, and you need to consistently use only one of those URLs to login.

I recommend renaming admin.php to something unique to your site such as hammer_time.php, then setting cp_url accordingly:

$config['cp_url'] = "http://example.com/hammer_time.php";
0
0

Do you have an htaccess rule or something else setup that block ajax requests? Is your site set to offline while you develop?

That error message is from EE, not Wyvern, so like the message says something else isn't configured correctly.

1
  • Nope, site is set to online, and nothing in .htaccess that would block ajax. Just a few redirects, and the Ellis Lab-approved method for removing index.php.
    – 4midori
    Mar 27 '15 at 16:03
0

I would put the third party themes and system folders into /system/expressionengine/config/config.php as config overrides like this:

// add-on themes path
config['path_third_themes'] = '/addons/themes/';
config['url_third_themes'] =  '/addons/themes/';

// add-on system path
$env_config['third_party_path']    = $base_path . '/addons/system/';

Be sure to change the above path to to be correct for your server.

2
  • Except EE is finding everything else it needs...is this a known fix?
    – 4midori
    Mar 31 '15 at 21:49
  • Just a suggestion. It may help, it may not, but it won't hurt to give it a shot.
    – CreateSean
    Apr 1 '15 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.