1

I have a form where I need to have a table submitted to Freeform in a text area. This is working correctly, however in the notification the table is not being rendered but is rather outputting raw html, see image.

I've set the notification template to allow html, I've also set the textarea to NOT prevent user html rendering.

Is there soemthing I'm missing?


UPDATE - I also set up freeform:entries and this field with the table inside it is outputting the table as entities and not html. Is there some way to get this working?


enter image description here

1

I found the solution to this. I had to wrap the code inside the textarea with {exp:ce_str:ing html_entity_decode}. Now everything works correctly

<textarea name="product_requests" style="display:none;">
    {exp:cookie_fav:favourites}
        {if has_favourites}
        {exp:ce_str:ing html_entity_decode}
        <table class="quote-items table table-striped">
            <thead>
                <tr>
                    <th>Product Id</th>
                    <th>Product Name/Description</th>
                    <th>Quantity</th>
                </tr>
            </thead>

            <tbody>
                {exp:channel:entries channel="product_page" limit="200" entry_id="{favourites_entry_ids}"}
                <tr>
                    <td class="prod_id">{product_id}</td>
                    <td class="prod_name">{title}</td>

                    <td class="prod_quantity">
                        {!--
                            Get Quantity set on Page 1
                        --}
                        {exp:evopost:getpostdata}
                            {ep_quantity_entry_{entry_id}}
                        {/exp:evopost:getpostdata}
                    </td>

                </tr>
                {/exp:channel:entries}
            </tbody>
        </table>
        {/exp:ce_str:ing}

        {/if}

        {if has_favourites == FALSE}
            <p>You haven't chosen any products to request a quote yet.</p>
        {/if}
{/exp:cookie_fav:favourites}
</textarea>
0

Under Admin/Email Settings try setting default email Format to html

2
  • Just tried that, no change.
    – CreateSean
    Apr 12 '15 at 16:25
  • updated my question with new information
    – CreateSean
    Apr 13 '15 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.