1

I have a channel form that users can enter their own calendar events into from behind a login. Randomly, some of the event dates do not get entered into the database. Looking at the tables, it appears that everything enters correctly except for the entry into the exp_calendar_events table. For the events that come through with no date, there is no corresponding row in this table.

I have tried to recreate this issue, but can't. The issue seems to be completely random based on who is entering the event.

The channel form code is:

{exp:channel:form channel="calendar_events" return="add-edit-events/updated-event" class="eventedit" include_jquery="no"}
    <fieldset>
        <legend>Event Date</legend>
        {exp:calendar:date_widget}
    </fieldset>
    <fieldset>
        <legend>Event Information</legend>
        <label class="required">Event Name:</label>
        <input type="text" name="title" value="{title}" /><br />
        <label>Event Category:</label><br />
        {category_menu}
                <select name="category[]" id="categories" size="4" multiple="multiple">
                        {select_options}
                </select>
        {/category_menu}<br />
        <i class="tip">* Please select as many categories as applicable. Selecting multiple categories can be done by holding the Ctrl key while clicking on categories.</i>
        <label>Location:</label>
        <input type="text" name="event_nolisting_location" value="{event_nolisting_location}"  /><br />
        <label>Facebook Page Title:</label>
        <input type="text" name="facebook_page_title" value="{facebook_page_title}"  /><br />
        <label>Facebook Link:</label>
        <input type="text" name="event_facebook" value="{event_facebook}"  /><br />
        <label>Cost:</label>
        <input type="text" name="event_cost" value="{event_cost}"  /><br />
        <label>Event Description:</label>
        {field:event_description}
        <label>Event Photo:</label>
        {field:event_image}
    </fieldset>
    <fieldset>
        <legend>More Information</legend>
        <label>Website Title:</label>
        <input type="text" name="event_sponsor" value="{event_sponsor}"  /><br />
        <label>Website:</label>
        <input type="text" name="event_sponsorlink" {if event_sponsorlink}value="{event_sponsorlink}"{if:else}value="http://"{/if}  /><br />
        <i class="tip">Please format the website address with http://</i>
    </fieldset>             
    <fieldset>
        <legend>Contact Details</legend>
        <label>Contact Name:</label>
        <input type="text" name="event_contact" value="{event_contact}"  /><br />
        <label>Contact Phone:</label>
        <input type="text" name="event_contactphone" value="{event_contactphone}"  /><br />
        <label>Contact Email:</label>
        <input type="text" name="event_contactemail" value="{event_contactemail}"  /><br />
    </fieldset>
    <input type="hidden" name="author_id" value="{member_id}" />
    <input type="hidden" name="allow_comments" value="n" />
{if freebie_3 != ""}
    <input type="hidden" name="url_title" value="{url_title}" />
{/if}
    <input type="hidden" name="status" value="closed" />
    <input type="submit" name="submit" value="Submit" class="calendar_submit button" />
{/exp:channel:form}

What would be causing the MySQL insert queries to not be happening?

  • Roughly how often does it appear to fail? Like 1 out of every 10 times, etc?Are you at all able to reproduce this is any way (where you can just get it to fail once, regardless of identifying a pattern/issue)? And if so, are you able to create a new template with nothing else in it except for a very simplified Channel Form and see if that makes any difference? :) – Solspace Apr 15 '15 at 21:17
  • Are the users attached to different member groups? Do the member groups have different posting priviledges? Are some users using Macs instead of PC's (I'm thinking of minor keyboard character differences causing invalid characters, ergo no date)? Lastly I assume the date widget is the classic calander pop up with a free text filed if so inclined? If so could it be some users entering a date textually with weird characters seperating D/M/Y, or users entering D/M/Y (english) while the widget is expecting americam M/D/Y format, causing invalid dates? Just a couple of questions that occur to me! – Blatant Apr 16 '15 at 12:27
  • I'd say that the failure rate is even lower than 1 in 10, probably 1 in every 25 to 30. I can not reproduce it in any way and the end user says that there is no pattern to the information entered in any calendar entry that appears across the failures. All members are attached the the Guests user group. Not sure on what the computer/browser of the users that fail are,. The widget is the default {exp:calendar:date_widget} tag, no modifications there. All users would be American and shouldn't have an English/American format issue. – Donovan Cronkhite Apr 16 '15 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.