0

We're using Editor (3.2.3) but we can't add a mailto-link. When using the link-button you get 3 options: URL, Site page and Email. When selecting e-mail we see a dropdown with the label 'link item' but the dropdown is empty. When creating a link this way it creates a empty href.

Any idea how to do this?

  • A screenshot of the editor modal window you're seeing might help too. – Romans-8---31-39 Apr 16 '15 at 12:49
1

Contact our DevDemon support. I believe this has been fixed with a bugfix.

| improve this answer | |
0

I went over to Redactor to try the editor out but the standard 'link' button behaves differently to how you describe. When I click the link icon it drops down with "Insert Link" and "Unlink".

Incidentally, if I select "Insert Link" I get 2 text boxes for "URL" and "Text" and a checkbo for "Open link in new tab", if I enter URL:mailto:me@my.com Text:me@my.com I get a mailto link exactly as I wanted!

Perhaps you could try adding a "URL" link, and for the URL entering the full mailto syntax, does that give you a decent link??

Also, can I ask what Redactor plug ins are loaded in with Editor? I don't have a licence to download Editor from DevDemon so I can't see for myself! Perhaps its loading the PredefinedLinks or another custom plugin to allow for EE integration (Site page for router pages, ect)?

| improve this answer | |
  • I thought of entering the mailto-syntax in the linkfield too, but the settings add http:// for every link. I don't want to turn that off, since our client is not that technical (they forget the http: otherwise). – snaderss Apr 16 '15 at 12:19
  • Of course, makes sense :) Perhaps you can have a dig around the module and identify the plugin thats giving you this alternative format of "Link" button? – Blatant Apr 16 '15 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.