2

I have a channel that includes a File field type. I have set two user groups to be able to upload all file types to that field. As a Super Admin I am able to upload there, but members of the other group cannot. I have set the upload directory permissions to 777 and I have confirmed that the group has permissions in EE to upload there - see attached. However, when logged in as a user of the other group, when I try to upload a PDF, I get an error that says:

The file could not be written to disk.

The file size is far less than the max file site allowed.

Normally I would think this is a directory permissions error. Any help would be appreciated for sorting this out.

enter image description here

3

With that error when uploading a PDF the first thing to take a look at is Admin ‣ Security and Privacy ‣ Security and Sessions and see whether "Apply XSS Filtering to Uploaded Files" is set to "yes." If it is, try setting it to "no" instead.

If that clears it up and you don't want to globally stop applying XSS filtering to uploaded files then there is a config override that will let you make only certain member group(s) exempt from the filtering. For example:

$config['xss_clean_member_group_exception'] = "6|7";

See this answer for more.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.