2

Hi there I am having issues upgrading from v2.5.3 to v2.9.3 the wizard starts fine and goes from 2.5.3 to 2.6.0, then moves onto the next step 2.7.0, but at this point I the server times out and I get the following message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

I have upgraded EE many times before, but not across the relationship change (from <2.6.0 to >2.7.0)... is this the issue? Surely it must be possible.

My install runs MSM and has Assets, Matrix and Playa installed along with some other add-ons. (all upgraded to the latest version) before running the wizard.

Hope you can help.

Edd

6
  • Can't think that the relationship change you mentioned is the problem. I upgraded from 2.5.0 to 2.9.3 this morning with no issues. Bizarre idea, but is it worth downloading 2.8.1 (the dropdown beside the Download button in Manage Your Purchases) and doing an upgrade to this, then upgrading to 2.9.3? Commented Apr 20, 2015 at 12:07
  • Hi Laura, thanks for you reply... actually tried upgrading to 2.8.1 first as well, but encountered the same issues.
    – EWDC
    Commented Apr 20, 2015 at 12:30
  • Laura, did your install have Assets, Playa or Matrix add-ons and MSM?
    – EWDC
    Commented Apr 20, 2015 at 12:31
  • 1
    What version of PHP is you server running? EE 2.9 requires PHP 5.3.10 or newer, and prior to that EE 2.6 - 2.9 required PHP 5.2.4 or newer. Commented Apr 20, 2015 at 12:33
  • Can you upgrade to 2.7.3? Definitely need to find out what PHP version your running like Derek said. An easy way to find out is under Tools > Utliities > PHP info. If you're running an older version of PHP then getting to 2.7.3 is really your only option. Commented Apr 20, 2015 at 14:40

1 Answer 1

1

Sometimes when EE does this, I enable PHP error reporting at the top of my index.php file and set $debug = 1.

ini_set('display_startup_errors',1);
ini_set('display_errors',1);
error_reporting(-1);

If you continue to get Internal Server Errors, try disabling your htaccess file (if using Apache).

If none of that helped, I strongly suggest you refer to your Apache or nginx error logs (if you're using either one of those). Report your findings and we'll be happy to help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.