0

I've got a site that works correctly on localhost and the staging domain, but after moving to the live server all interior pages return a 404 page.

.htaccess has the following

<IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /

        # Removes index.php from ExpressionEngine URLs
        RewriteCond %{THE_REQUEST} ^GET.*index\.php [NC]
        RewriteCond %{REQUEST_URI} !/cms/.* [NC]
        RewriteRule (.*?)index\.php/*(.*) /$1$2 [R=301,NE,L]

        # Directs all EE web requests through the site index file
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ /index.php/$1 [L]
</IfModule>

EE is not running in a subdirectory, i've tried adding the query string option from the docs but no change. Also removed the leading slash from index.php but that didn't make a difference.

Any thoughts? hosted on rackspace

  • it appears that .htaccess is being deleted by the server. I can see it when uploaded, but when I exit ftp and go back in it's missing. Talking to host now – CreateSean Apr 21 '15 at 12:38
  • this may also be the display settings on your chosen FTP agent, FileZilla by any chance?? rackspace.com/knowledge_center/article/… – Blatant Apr 21 '15 at 16:12
  • Turns out Rackspace had misconfigured the vhost – CreateSean Apr 22 '15 at 13:04
2

Are you sure mod_rewrite is installed & enabled? My guess is no!

  • I would also concure with this :) I'd give it 99% chance! Remove your .htaccess (upload a blank one if you're having issues seeing .htaccess) and set your index page to index.php to test. – Blatant Apr 21 '15 at 16:12
  • Agreed. A good way to prove it is to simply remove the "<IfModule mod_rewrite.c>" and "</IfModule>" logic. If you get an Internal Server Error afterwards, the module isn't installed. – Jarrett Barnett Apr 22 '15 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.