0

So I have a site on production, but I wanted to be able to work on it locally too, like when I have no web access. I know it's the backward way of doing things, and not sure how it's ended up like this. Anyway.

I installed EE locally, then imported my production database, now when I login it just refreshes. I keep asking for a new password, but it still refreshes and doesn't login.

What am I doing wrong?

0

To troubleshoot, first try setting your control panel sessions to be cookie based only:

Add this to /system/expresionengine/config/config.php

$config['cp_session_type'] = 'c';

If that doesn't work, try disabling extensions via your config file:

$config['allow_extensions'] = 'n';

If that allows you to login, it's likely an add-on that's redirecting to a URI that's either invalid or redirected (thereby rejecting your POST data). You can confirm/observe this by viewing your "Network" log in your Developer Tools.

For me, the easiest solution is to just disable redirects on control panel login. You can either delete the cp_member_login hooks from the exp_extensions database table or try updating Structure (or the suspected add-on) to not redirect on login. Note that it's possible that you have more than one app trying to redirect (e.g. Republic Analytics, Structure, etc)

| improve this answer | |
0

I've had this problem before and, for me, it has nearly always been caused by cookie configuration. You can try adding your local address to the config file with $config['cookie_domain'] = "[your local url]" to make sure that cookies are being served from the correct domain (ie: the one you are using locally). You could also try putting in an empty config value in (such as $config['cookie_domain'] = "" ) to see if that works.

| improve this answer | |
  • Hi, this still doesn't work. It still refreshes with a blank login form, using both local url and empty value. Perhaps a re-install? – Nick Toye Apr 25 '15 at 20:44
  • There's a bit more info on this thread which may help you expressionengine.stackexchange.com/questions/10604/… Also, it may be obvious, but dio check that you've cleared your session and domain cookies as well. – Anthony Mellor Apr 27 '15 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.