0

The issue I seem to be having is that I have a member template set up with form fields and 2 of the fields seem to be buggy. For the most part all the fields submit to the admin but the issue is when I try to edit the form on the site after logging in, I get errors displayed in the email area (span data-eeEncEmail_sPFGNXeWik=)(JavaScript must be enabled to view this email address)'/> and the Web Address area.

The template code for those fields looks like this {exp:zoo_visitor:update_form include_assets="yes" return="/employee-portal" } {exp:zoo_visitor:details}

Edit profile

            <label for="member_email_address">{label:member_email_address}</label>
            <input type="text" name="member_email_address" id="member_email_address" value='{if visitor:email_address}{visitor:email_address}{/if}'/>
        </p>          
        <p>
            <label for="member_website">{label:member_website}</label>
            <input type="text" name="member_website" id="member_website" value="{if visitor:website}{visitor:website}{/if}"/>
        </p>
        <p>

Not sure why this is displaying in the form?

enter image description here

0

EDIT

Scrap my last, I've worked out what your issue is. EE automatically encodes URL's and Email addresses on output! this is what you're seeing...

Unfortunatly there's no way to turn it off per use, so to speak...

What you'll have to do is turn off auto encoding (see below) for the Zoo Visitor channel (Zoo Visitor uses a channel to add extra fields to users), then call it manually whenever you want to display the encoded version (encoding basically turns URL's into links and email addresses into JS obfuscated output to stop crawlers).

You’ll need to turn off “Automatically turn URLs and email addresses into links?” here: Admin > Channel Administration > Channels > [Your Channel] > Edit Preferences.

To use the encoded version you can use the {encode} tag to force it.

That should get you rocking :) Let us know how you get on...

Looks to me like the {visitor:email_address} and {visitor:website} tags are returning HTML for the email address/website fields. i.e. for the email it looks like its serving you a span with some stuff in it, for the website it looks like a link. of course if you push these straight into the value fields they'll break all over the place.

Can you append the following to your template and let us know the output ?

<pre>
    {visitor:email_address}
    ----------------------------
    {visitor:website}
</pre>

Can you also tell us exactly what field type these 2 fields are (i'm guessing ome form of specific email address field and a Link field)? I can then take a punt at the exact answer for you... This should tell us if HTML is being output, then all we need to do if figure out how to get the correct value you're looking for!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.