1

I have a client site where there was a custom YouVersion button added to WYGWAM that stopped working after updating all the things.

It's working on an Ee 2.6.1 / Wygwam 2.7.1 site. It's now running EE 2.10 Wygwam 3.3.3 and not working.

There is a YouVersion folder/addon installed in: /themes/third_party/wygwam/lib/ckeditor/plugins

"YouVersion" is specified in the Wygwam config, alongside a drop-down value of "extraPlugins".

The YouVersion button just doesn't appear. Nor do any of the other I see in the plugins folder and add in the extraPlugins list.

This is on a dev server, but I didn't see any pathing specified that might be affecting things.

Anything else I should look for?

  • anything showing in the console when watching the cp page in question? – erwinheiser Jun 12 '15 at 14:41
  • Nope. Nope. Nope. ( I hate minimum reply lengths). – Michael Boyink Jun 12 '15 at 14:49
  • What's the vector that adds this button to WYGWAM? The word custom makes me think there was a core edit to the WYGWAM files to get in in the toolbar and functional. Is there a JavaScript asset this YouVersion thing should be loading in the CP entry_form? If so start by seeing if it shows up in the network/resources section of your browsers dev console. – jrothafer Jun 13 '15 at 4:06
  • The answers to your question are in my original question...;) – Michael Boyink Jun 13 '15 at 10:54
  • Have you thought about just creating a template with whatever code you need? Templates in WYGWAM are quite powerful. – Mark Busnelli Jr Jun 14 '15 at 13:32
1

I beleive this is because wit hthe update of WYGWAM comes an update to CKEditor (the editor under the hood). YOu've upgraded from CKEditor 3 to 4 in the same upgrade.

This means in turn that your v3 plugin (YouVersion) is not correctly formatted for CKEditor 4.

That or (from my memory which isn't super strong) I believe the way you add plugins to WYGWAM changed with the major version upgrade. Best to follow the documentation here : http://docs.pixelandtonic.com/wygwam/developers/ckeditor_plugins.html

This may be of help, but might be out of date : Adding CKEditor Plugins to Wygwam

| improve this answer | |
  • Thanks - I'm still trying to follow the logic with their docs. The pre-upgrade site didn't have an EE extension involved so that's confusing me. – Michael Boyink Jun 15 '15 at 18:13
  • Well, I'd be inclined to check your Plugin is CKEditor4 compatible (and get a newer version if not), then follow the guide over at P&T carefully and methodically, as I recall getting a plugin in CKEditor in WYGWAM in EE FieldType (in a Taco Bell) is a bit confusing. Meanwhile if you wish to develop the question with your extension issues (try to be specific) edit the OP and we'll be happy to help. Either way do keep us updated on how you get on! – Blatant Jun 16 '15 at 8:49
  • The issue has been put on hold by the client (too many hoops/billable hours for the functionality the plugin provided). – Michael Boyink Jun 16 '15 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.